Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Some customers in Brazil may be unable to create cards, receive payment notifications, update card details, or complete onboarding.
Resolved
·
Full outage
Fri, Jun 12, 2026, 05:40 PM
(
1
hour ago)
·
View all updates
Affected components
03:54 PM
05:40 PM
Clara Web Platform
Updates
Resolved
Resolved incident
Fri, Jun 12, 2026, 05:40 PM
Investigating
Investigating issue
Fri, Jun 12, 2026, 03:54 PM
(
1
hour earlier)
Some customers in Brazil may be unable to create cards, receive payment notifications, update card details, or complete onboarding. - Clara Status