Subscribe to updates
Minsait is down in all countries
Resolved
·
Full outage
Issue resolved
Thu, Oct 23, 2025, 02:35 PM
(
1
month ago)
·
View all updates
Affected components
Oct 23, 2025, 10:32 AM
02:35 PM
Clara Web Platform
Updates
Resolved
Issue resolved
Thu, Oct 23, 2025, 02:35 PM
Investigating
Investigating issue
Thu, Oct 23, 2025, 10:32 AM
(
4
hours earlier)
Powered by
Privacy policy
·
Terms of service