Subscribe to updates
Failure rate increase to 59.3% on /transactions/approval/v2/request/[UUID] endpoint
Resolved
Thu, Sep 25, 2025, 08:27 PM
(
2
months ago)
·
View all updates
Affected components
No components marked as affected
Updates
Resolved
Resolved incident
Thu, Sep 25, 2025, 08:27 PM
Investigating
Investigating issue
Wed, Sep 17, 2025, 08:59 PM
(
1
week earlier)
Powered by
Privacy policy
·
Terms of service